FORMÜLÜ MAKRO İLE HÜCREYE EKLEME

FORMÜLÜ MAKRO İLE HÜCREYE EKLEME

#2728 İleti | nadir | 27 Arl 2020, 19:36

Aşağıdaki formülü C3 hücresine makro ile nasıl eklerim; C3'ten itibaren de C100' e kadar çoğaltmak istiyorum.

=DÜŞEYARA(B3;OKULLAR.$B$2:$D$180;2;0)

veya makro ile DÜŞEYARA kodu da olabilir.

Makro kaydet ile yapmayı denediğimde hücre içeriğini okumuyor. Dolayısıyla hücreye yazılan formül kodda gözükmüyor.İlginç...
nadir
 
İleti: 16
Kayıt: 14 Eyl 2020, 13:09
İşletim Sisteminiz: Windows 10
LibreOffice Sürümü: 7

Re: FORMÜLÜ MAKRO İLE HÜCREYE EKLEME

#2735 İleti | Hamurcu | 29 Arl 2020, 22:10

Merhaba

Aşağıdaki şekilde yapabilirsiniz.

Kod: Tümünü seç
Sub FormulEkle
  ThisComponent.CurrentController.ActiveSheet.getCellByPosition(1,1).setFormula("=DÜŞEYARA(B3;OKULLAR.$B$2:$D$180;2;0)")

End Sub
Kullanıcı avatarı
Hamurcu
 
İleti: 223
Kayıt: 06 Ağu 2012, 00:14
Konum: İstanbul
İşletim Sisteminiz: Windows 10
LibreOffice Sürümü: 6.x

Re: FORMÜLÜ MAKRO İLE HÜCREYE EKLEME

#2736 İleti | Hamurcu | 29 Arl 2020, 23:17

Burada

Kod: Tümünü seç
getCellByPosition(SutunNo,SatırNo)


Olarak kullanacaksınız.

Unutmayın her ikisi de 0 dan (Sıfır) başlar.

Yani getCellByPosition(3,16) demek aslında 4. sütun, 17. satır anlamına gelir.
Kullanıcı avatarı
Hamurcu
 
İleti: 223
Kayıt: 06 Ağu 2012, 00:14
Konum: İstanbul
İşletim Sisteminiz: Windows 10
LibreOffice Sürümü: 6.x

Re: FORMÜLÜ MAKRO İLE HÜCREYE EKLEME

#2739 İleti | nadir | 05 Oca 2021, 23:48

Teşekkürler, ancak kodu çalıştırdığımda DÜŞEYARA hücreye küçük harfle aktarılıyor, bu da formülde AD hatasına sebep oluyor.
nadir
 
İleti: 16
Kayıt: 14 Eyl 2020, 13:09
İşletim Sisteminiz: Windows 10
LibreOffice Sürümü: 7

Re: FORMÜLÜ MAKRO İLE HÜCREYE EKLEME

#2740 İleti | Hamurcu | 06 Oca 2021, 21:31

Yaptığın örnek dosyayı foruma yazacağın mesaja eklersen kontrol edelim.
Kullanıcı avatarı
Hamurcu
 
İleti: 223
Kayıt: 06 Ağu 2012, 00:14
Konum: İstanbul
İşletim Sisteminiz: Windows 10
LibreOffice Sürümü: 6.x


Calc - Hesap Tablosu

Kimler çevrimiçi

Kayıtlı kullanıcılar: Google [Bot]

cron