Bug: 83104

Forum kuralları
LibreOffice Bugzilla'ya başlık açılmış hatalar.

Bug: 83104

#1420 İleti | sabriunal | 15 Eyl 2014, 00:58

Kaynak: https://www.libreoffice.org/bugzilla/sh ... i?id=83104
Bildiren: Zeki Bildirici
Durum: UNCONFIRMED

EDITING: Calc text auto completion does not avoid suggestions starting with numbers

Hi,

Currently Calc auto completion does not avoid numbers. When you entered a cell beginning with number and followed by text, calc will try to autocomlete the cells which starts the number entered previously.

For example if you type ''1. Month'' or ''7000 bullets'' to A1, Calc will autocomplete every cell which starts with 1 or 7

This is really annoying because if you have a table with rows/coloums text+number combination every number entry will suggest you the label again. Also it is forcing users to make mistake, every number you'll need to click backspace and make sure it is "the number" and slows the user.

I am attaching a screenshot for Calc vs Ms Excel autocompletion comparison.



Steps to reproduce:
1. Type a number+ text(or sign) combination to a cell
2. Type the number and see the autocompletion suggestion

Current behavior:

Numbers are not avoided

Expected behavior:
Autocompletion suggestions which are starting with numbers are disabled.
Operating System: All
Version: 4.3.0.4 release
Kullanıcı avatarı
sabriunal
 
İleti: 299
Kayıt: 31 Tem 2012, 23:26

Bildirilen Hatalar

Kimler çevrimiçi

Kayıtlı kullanıcılar: Google [Bot], Tbot