Satır eklerken formül başvuruları genişletiliyor.

Satır eklerken formül başvuruları genişletiliyor.

#1524 İleti | Dostulaş2 | 06 Oca 2015, 00:36

Sistem: Ubuntu 14.10 64 Bit
LibreOffice: 4.3.3.2 İnşa: 430m0(Build:2)

A1:C4 arası sayılar var D1:D4'te de ilgili satırların toplam formülü var.
D1: =TOPLA(A1:C1)
D2: =TOPLA(A2:C2)
D3: =TOPLA(A3:C3)
D4: =TOPLA(A4:C4)

İkinci satıra yeni bir satır eklediğimde D1:D5'teki formüller aşağıdaki gibi oluyor
D1: =TOPLA(A1:C2)
D2:
D3: =TOPLA(A2:C3)
D4: =TOPLA(A3:C4)
D5: =TOPLA(A4:C5)

Bu formüllerin satır ekleme işleminde sonra aşağıdaki gibi olmasını bekliyorum.
D1: =TOPLA(A1:C1)
D2:
D3: =TOPLA(A3:C3)
D4: =TOPLA(A4:C4)
D5: =TOPLA(A5:C5)

İşin daha garip tarafı da var. Yukarıdakiler Sayfa1'de. Sayfa2'ye aynı veri ve formülleri aynı konuma kopyaladım.
Sayfa1'de 2. satıra yeni bir satır eklediğimde yukarıdaki sorunun yanında Sayfa2'deki formülleri de genişletiyor.
Sayfa2'deki D sütunundaki formüller aşağıdaki hale geliyor.
D1: =TOPLA(A1:C2)
D2: =TOPLA(A2:C3)
D3: =TOPLA(A3:C4)
D4: =TOPLA(A4:C5)

Not: Sayfa1 ve Sayfa2 aynı anda seçili değil.

30'dan fazla sayfası olan belgemde işkence çekiyorum.
Yardımlarınızı acilen bekliyorum.
Dostulaş2
 
İleti: 7
Kayıt: 20 Nis 2014, 15:25
İşletim Sisteminiz: ubuntu 14.10
LibreOffice Sürümü: 4.3.3.2

Re: Satır eklerken formül başvuruları genişletiliyor.

#1526 İleti | kobzeci | 06 Oca 2015, 18:52

Merhaba,

Sanıyorum ki sizde Araçlar - Seçenekler - LibreOffice Calc yolunda "Araya yeni sütunkar satırlar eklendiğinde başvuruyu genişlet seçeneği aktif. Kutucuktaki işareti kaldırıp tamam'a basın.

Seçeneklerde daha önce bir değişiklik yapmış mıydınız?
kobzeci
 
İleti: 264
Kayıt: 01 Ağu 2012, 10:07

Re: Satır eklerken formül başvuruları genişletiliyor.

#1527 İleti | Dostulaş2 | 06 Oca 2015, 21:03

Teşekkürler,
Aynen dediğin gibi kobzeci, çözümü bulmuş ve buraya yazacakken cevabını okudum. Dediğinin aynını yaptım sorun çözüldü.
Fakat bir sayfaya satır eklenmesiyle diğer sayfaların formüllerinin de genişlemesi çok anlamsız. Bence bu bir hata...
Dostulaş2
 
İleti: 7
Kayıt: 20 Nis 2014, 15:25
İşletim Sisteminiz: ubuntu 14.10
LibreOffice Sürümü: 4.3.3.2


Calc - Hesap Tablosu

Kimler çevrimiçi

Kayıtlı kullanıcılar: Google [Bot], Google Feedfetcher, Yahoo [Bot], Yandex [Bot]