FORMÜLÜ MAKRO İLE HÜCREYE EKLEME

Cevapla
nadir
Mesajlar: 22
Kayıt: 14 Eyl 2020, 13:09
İşletim Sisteminiz: Windows 10
LibreOffice Sürümü: 7

FORMÜLÜ MAKRO İLE HÜCREYE EKLEME

Mesaj gönderen nadir »

Aşağıdaki formülü C3 hücresine makro ile nasıl eklerim; C3'ten itibaren de C100' e kadar çoğaltmak istiyorum.

=DÜŞEYARA(B3;OKULLAR.$B$2:$D$180;2;0)

veya makro ile DÜŞEYARA kodu da olabilir.

Makro kaydet ile yapmayı denediğimde hücre içeriğini okumuyor. Dolayısıyla hücreye yazılan formül kodda gözükmüyor.İlginç...
Kullanıcı avatarı
Hamurcu
Mesajlar: 237
Kayıt: 06 Ağu 2012, 00:14
İşletim Sisteminiz: Windows 10
LibreOffice Sürümü: 7.x
Konum: İstanbul
İletişim:

Re: FORMÜLÜ MAKRO İLE HÜCREYE EKLEME

Mesaj gönderen Hamurcu »

Merhaba

Aşağıdaki şekilde yapabilirsiniz.

Kod: Tümünü seç

Sub FormulEkle
  ThisComponent.CurrentController.ActiveSheet.getCellByPosition(1,1).setFormula("=DÜŞEYARA(B3;OKULLAR.$B$2:$D$180;2;0)")

End Sub
Kullanıcı avatarı
Hamurcu
Mesajlar: 237
Kayıt: 06 Ağu 2012, 00:14
İşletim Sisteminiz: Windows 10
LibreOffice Sürümü: 7.x
Konum: İstanbul
İletişim:

Re: FORMÜLÜ MAKRO İLE HÜCREYE EKLEME

Mesaj gönderen Hamurcu »

Burada

Kod: Tümünü seç

getCellByPosition(SutunNo,SatırNo)
Olarak kullanacaksınız.

Unutmayın her ikisi de 0 dan (Sıfır) başlar.

Yani getCellByPosition(3,16) demek aslında 4. sütun, 17. satır anlamına gelir.
nadir
Mesajlar: 22
Kayıt: 14 Eyl 2020, 13:09
İşletim Sisteminiz: Windows 10
LibreOffice Sürümü: 7

Re: FORMÜLÜ MAKRO İLE HÜCREYE EKLEME

Mesaj gönderen nadir »

Teşekkürler, ancak kodu çalıştırdığımda DÜŞEYARA hücreye küçük harfle aktarılıyor, bu da formülde AD hatasına sebep oluyor.
Kullanıcı avatarı
Hamurcu
Mesajlar: 237
Kayıt: 06 Ağu 2012, 00:14
İşletim Sisteminiz: Windows 10
LibreOffice Sürümü: 7.x
Konum: İstanbul
İletişim:

Re: FORMÜLÜ MAKRO İLE HÜCREYE EKLEME

Mesaj gönderen Hamurcu »

Yaptığın örnek dosyayı foruma yazacağın mesaja eklersen kontrol edelim.
Cevapla